Use libtool and compile libht as a shared library.
[ashd.git] / src / Makefile.am
index ed1f0ce..73d21bc 100644 (file)
@@ -1,12 +1,12 @@
 SUBDIRS = dirplex
 
 bin_PROGRAMS = htparser sendfile callcgi patplex userplex htls \
-               callscgi accesslog htextauth
-noinst_PROGRAMS = debugsink
+               callscgi accesslog htextauth callfcgi multifscgi \
+               errlogger
 
 htparser_SOURCES = htparser.c htparser.h plaintcp.c ssl-gnutls.c
 
-LDADD = $(top_srcdir)/lib/libht.a
+LDADD = $(top_srcdir)/lib/libht.la
 AM_CPPFLAGS = -I$(top_srcdir)/lib
 
 htparser_CPPFLAGS = $(AM_CPPFLAGS) @GNUTLS_CPPFLAGS@