etc: Add environment option to run init.d/ashd silently.
[ashd.git] / src / Makefile.am
index 0a1a7d9..3bc8963 100644 (file)
@@ -2,14 +2,14 @@ SUBDIRS = dirplex
 
 bin_PROGRAMS = htparser sendfile callcgi patplex userplex htls \
                callscgi accesslog htextauth callfcgi multifscgi \
-               errlogger
-noinst_PROGRAMS = debugsink
+               errlogger httimed psendfile httrcall htpipe ratequeue
 
-htparser_SOURCES = htparser.c htparser.h plaintcp.c ssl-gnutls.c
+htparser_SOURCES = htparser.c htparser.h plaintcp.c ssl-gnutls.c ssl-openssl.c
 
 LDADD = $(top_srcdir)/lib/libht.a
 AM_CPPFLAGS = -I$(top_srcdir)/lib
 
-htparser_CPPFLAGS = $(AM_CPPFLAGS) @GNUTLS_CPPFLAGS@
-htparser_LDADD = $(LDADD) @GNUTLS_LIBS@
+htparser_CPPFLAGS = $(AM_CPPFLAGS) @GNUTLS_CPPFLAGS@ @OPENSSL_CPPFLAGS@
+htparser_LDADD = $(LDADD) @GNUTLS_LIBS@ @OPENSSL_LIBS@
 sendfile_LDADD = $(LDADD) -lmagic @XATTR_LIBS@
+psendfile_LDADD = $(LDADD) -lmagic @XATTR_LIBS@