Added a preliminary version of a psendfile program.
[ashd.git] / src / Makefile.am
index b3c9a65..394e353 100644 (file)
@@ -1,8 +1,17 @@
-bin_PROGRAMS = htparser
-noinst_PROGRAMS = debugsink
+SUBDIRS = dirplex
 
-htparser_SOURCES = htparser.c
-debugsink_SOURCES = debugsink.c
+bin_PROGRAMS = htparser sendfile callcgi patplex userplex htls \
+               callscgi accesslog htextauth callfcgi multifscgi \
+               errlogger
+
+noinst_PROGRAMS=psendfile
+
+htparser_SOURCES = htparser.c htparser.h plaintcp.c ssl-gnutls.c
 
 LDADD = $(top_srcdir)/lib/libht.a
 AM_CPPFLAGS = -I$(top_srcdir)/lib
+
+htparser_CPPFLAGS = $(AM_CPPFLAGS) @GNUTLS_CPPFLAGS@
+htparser_LDADD = $(LDADD) @GNUTLS_LIBS@
+sendfile_LDADD = $(LDADD) -lmagic @XATTR_LIBS@
+psendfile_LDADD = $(LDADD) -lmagic @XATTR_LIBS@