Added a htls program for directory listings.
[ashd.git] / src / Makefile.am
index 14a2d06..32e50fb 100644 (file)
@@ -1,6 +1,11 @@
-bin_PROGRAMS = htparser
+bin_PROGRAMS = htparser dirplex sendfile callcgi patplex userplex htls
+noinst_PROGRAMS = debugsink
 
-htparser_SOURCES = htparser.c
+htparser_SOURCES = htparser.c htparser.h plaintcp.c
+dirplex_SOURCES = dirplex.c
+debugsink_SOURCES = debugsink.c
 
-htparser_LDADD = $(top_srcdir)/lib/libht.a
-htparser_CPPFLAGS = -I$(top_srcdir)/lib
+LDADD = $(top_srcdir)/lib/libht.a
+AM_CPPFLAGS = -I$(top_srcdir)/lib
+
+sendfile_LDADD = $(LDADD) -lmagic @XATTR_LIBS@