Added the `ratequeue' program.
[ashd.git] / src / Makefile.am
index 738d8a1..1c1b8a8 100644 (file)
@@ -1,9 +1,10 @@
-bin_PROGRAMS = htparser dirplex sendfile callcgi patplex userplex htls
-noinst_PROGRAMS = debugsink
+SUBDIRS = dirplex
+
+bin_PROGRAMS = htparser sendfile callcgi patplex userplex htls \
+               callscgi accesslog htextauth callfcgi multifscgi \
+               errlogger httimed psendfile httrcall htpipe ratequeue
 
 htparser_SOURCES = htparser.c htparser.h plaintcp.c ssl-gnutls.c
-dirplex_SOURCES = dirplex.c
-debugsink_SOURCES = debugsink.c
 
 LDADD = $(top_srcdir)/lib/libht.a
 AM_CPPFLAGS = -I$(top_srcdir)/lib
@@ -11,3 +12,4 @@ AM_CPPFLAGS = -I$(top_srcdir)/lib
 htparser_CPPFLAGS = $(AM_CPPFLAGS) @GNUTLS_CPPFLAGS@
 htparser_LDADD = $(LDADD) @GNUTLS_LIBS@
 sendfile_LDADD = $(LDADD) -lmagic @XATTR_LIBS@
+psendfile_LDADD = $(LDADD) -lmagic @XATTR_LIBS@