python: Moved the Python 3 files to their own directory and restored Python 2 files.
[ashd.git] / python3 / setup.py
diff --git a/python3/setup.py b/python3/setup.py
new file mode 100755 (executable)
index 0000000..4fdef01
--- /dev/null
@@ -0,0 +1,17 @@
+#!/usr/bin/python3
+
+from distutils.core import setup, Extension
+
+htlib = Extension("ashd.htlib", ["htp.c"],
+                  libraries = ["ht"])
+
+setup(name = "ashd-py",
+      version = "0.4",
+      description = "Python module for handling ashd requests",
+      author = "Fredrik Tolf",
+      author_email = "fredrik@dolda2000.com",
+      url = "http://www.dolda2000.com/~fredrik/ashd/",
+      ext_modules = [htlib],
+      packages = ["ashd"],
+      scripts = ["ashd-wsgi3", "scgi-wsgi3"],
+      license = "GPL-3")