lib: Split epoll and select loops into separate files.
[ashd.git] / lib / Makefile.am
index 4cfeaa2..d48cfb6 100644 (file)
@@ -1,7 +1,12 @@
 lib_LIBRARIES = libht.a
 
 libht_a_SOURCES =      utils.c mt.c log.c req.c proc.c mtio.c resp.c cf.c
-libht_a_CFLAGS = -fPIC
-libht_a_CPPFLAGS = -D_GNU_SOURCE
+libht_a_CFLAGS =       -fPIC
+libht_a_CPPFLAGS =     -D_GNU_SOURCE
+if USE_EPOLL
+libht_a_SOURCES += mtio-epoll.c
+else
+libht_a_SOURCES += mtio-select.c
+endif
 
 pkginclude_HEADERS =   utils.h mt.h log.h req.h proc.h mtio.h resp.h cf.h