lib: Added a kqueue mtio implementation.
[ashd.git] / lib / Makefile.am
index 8116805..30de42a 100644 (file)
@@ -5,7 +5,11 @@ libht_a_CFLAGS =       -fPIC
 if USE_EPOLL
 libht_a_SOURCES += mtio-epoll.c
 else
+if USE_KQUEUE
+libht_a_SOURCES += mtio-kqueue.c
+else
 libht_a_SOURCES += mtio-select.c
 endif
+endif
 
 pkginclude_HEADERS =   utils.h mt.h log.h req.h proc.h mtio.h resp.h cf.h