Use libtool and compile libht as a shared library.
[ashd.git] / lib / Makefile.am
index a41cde0..88056a0 100644 (file)
@@ -1,6 +1,6 @@
-noinst_LIBRARIES = libht.a
+lib_LTLIBRARIES = libht.la
 
-libht_a_SOURCES =      utils.c mt.c log.c req.c proc.c mtio.c resp.c cf.c \
+libht_la_SOURCES =     utils.c mt.c log.c req.c proc.c mtio.c resp.c cf.c \
                        utils.h mt.h log.h req.h proc.h mtio.h resp.h cf.h
-libht_a_CFLAGS = -fPIC
-libht_a_CPPFLAGS = -D_GNU_SOURCE
+libht_la_CPPFLAGS = -D_GNU_SOURCE
+libht_la_LDFLAGS = -version-info 1:0:0