Added build procedure for manpages and HTML documentation.
[ashd.git] / doc / Makefile.am
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644 (file)
index 0000000..66b4a0b
--- /dev/null
@@ -0,0 +1,14 @@
+dist_man1_MANS = callcgi.1 dirplex.1 htparser.1 patplex.1 sendfile.1 userplex.1
+dist_man7_MANS = ashd.7
+
+%.7 %.1: %.doc
+       a2x -f manpage $<
+
+%.html: %.doc
+       a2x -f xhtml $<
+
+manpages: $(dist_man1_MANS) $(dist_man7_MANS)
+
+htmldoc: $(patsubst %.doc, %.html, *.doc)
+
+EXTRA_DIST = *.doc